Commit 580b2e3c authored by Alexey Dobriyan's avatar Alexey Dobriyan Committed by Linus Torvalds

[PATCH] Adapt scripts/ver_linux to new util-linux version strings

Tested with 2.12i and 2.13-pre2.
Signed-off-by: default avatarAlexey Dobriyan <adobriyan@gmail.com>
Signed-off-by: default avatarAndrew Morton <akpm@osdl.org>
Signed-off-by: default avatarLinus Torvalds <torvalds@osdl.org>
parent e752dd6c
......@@ -25,9 +25,11 @@ ld -v | awk -F\) '{print $1}' | awk \
'/BFD/{print "binutils ",$NF} \
/^GNU/{print "binutils ",$4}'
fdformat --version | awk -F\- '{print "util-linux ", $NF}'
echo -n "util-linux "
fdformat --version | awk '{print $NF}' | sed -e s/^util-linux-// -e s/\)$//
mount --version | awk -F\- '{print "mount ", $NF}'
echo -n "mount "
mount --version | awk '{print $NF}' | sed -e s/^mount-// -e s/\)$//
depmod -V 2>&1 | awk 'NR==1 {print "module-init-tools ",$NF}'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment